Join Us at the New Logos Bible Software Forums

Since 2002 we’ve had an active group of users on our newsgroups. After much deliberation we’ve decided that it’s time to make the switch to web forums. We’ve been testing them with a small group for a couple of weeks, and now we’re ready to invite you to come join the discussions at the new Logos Bible Software Forums.

To use the Logos forums, you’ll need to be logged in to your account. If you don’t have one, you can sign up for one now. Already have one? Sign in and head on over to, or just click the new Forums link in the navigation at the top left of any site.

If you happen to get an “Access Denied” message, your cookies need to be updated. Most of the time logging out of your account (top right hand corner of and then back in again will take care of the problem. If that doesn’t work, delete any * cookies, restart your browser, sign in at, and then return to the forums.

If you’re fairly new to Logos and are looking for some help learning the ropes, the forums will be the perfect place to get help from our top-notch group of power users who love to help others learn how to use Logos Bible Software better.

We look forward to seeing you at the Logos forums!


  1. I was very glad to see Logos go web based, because that is where we will be able to build more of a Logos user community because most people won’t use NNTP. Two brief points of input:
    1. I would really like to see the ability to use NNTP with these forums (dual use). I understand from something I read written by Bob that this was in the original plan. I do hope that this is not being abandoned, because NNTP is a very efficient way to dialogue.
    2. Jump to the last read post in many threads is not working. Which means if you have read a thread previously, you have to dig through to find the last one that you read manually. (This is where NNTP comes into its own). I hope this is fixed.
    It is a great day to see this web forum running! We have waited a long time for it! :)

  2. Excellent! Just what I’ve been waiting for.

  3. Thanks for introducing the forums. Some places I go do not have a newsreader installed, or they have firewall policies in place that prevent access news servers. The forums have removed this problem.
    Now, a stylistic request. How about bringing the look and feel of all of your web products together? The forums have one look (very nice), the Bible and Sermons have another (not very good, but that is just my opinion), this blog has another, and your main site yet another!
    How about some consistency?
    Thanks again for a great product, and great service.

  4. steve cheek says

    I tried to sign up fot the forums but we are required to type in a phrase found on the page. I cannot read the phrase. Any help?

  5. Thanks for the feedback, Donovan. We’re working on the unread posts issue. Hopefully we’ll have that improved soon.

  6. Eddie Beal says

    Phil, tried to access the forums and I get an error even though I went in through the Logos home page and was logged in. My email address is not my Logos ID though and it is my email address that it is telling me is being denied.
    After saying “access denied for (my email address)” it says:
    The account you are attempting to login with could not be completely activated.
    Please contact your site administrator to activate the account or enable automatic account activation.
    Something else I need to do?

  7. Did you try logging out and then back in again? Did you try deleting your * cookies? If neither of those works, let us know.

  8. Phil Gons says

    We’re moving that way, Chuck. That’s for the suggestion!

  9. You should only need your username and password to sign in. If you don’t already have a username and password, you can sign up for one without typing any special phrases in. Are you trying to log in with an existing account or create a new one?

  10. I am having the same problem as Eddie. I cannot sign on to the site and get an access denied message.
    Sam Lamerson

  11. Sam, try logging out of your account and then back in again. If that doesn’t work, try deleting your * cookies. That should do the trick.