Libronix 3.0f Now Shipping—Update for Free!

Last night we released the next minor update to our Libronix Digital Library System for Windows. If you are planning to install Microsoft’s Internet Explorer 8 (or if you already have), it is vital that you update to Libronix 3.0f to avoid some minor incompatibility problems. Best of all, the update is completely free.

In addition to the IE8 compatibility fixes, 3.0f includes several bug fixes and improvements, as well as updates to a number of resources and lectionaries. For a complete list of all of the bug fixes and changes, see the new support article.

To update, simply open Libronix and go to Tools > Libronix Update. After it looks for available updates, click “Update,” close Libronix, and then wait for the updates to download and install. When installation is complete, click “Close” and then restart Libronix.

On Facebook? Join the Discussion

17 Responses to “Libronix 3.0f Now Shipping—Update for Free!”

  1. JA March 25, 2009 at 8:07 am #

    I was running 3.0f RC3 and the updater said there were no new updates. I did, however, notice that in the info window the RC3 part is gone. Is RC3 identical to the version you just released?

  2. Phil Gons March 25, 2009 at 8:30 am #

    Yes, RC3 is the version that shipped, so you should be all set.

  3. Len Flack March 25, 2009 at 8:55 am #

    Any chance a “Libronix for Mac 1.0a” with compatibility with Safari 4.0 is in the works? ;-)

  4. Phil Gons March 25, 2009 at 9:39 am #

    Len, we do have a new version of Logos for Mac coming out very soon, with another in the works. I don’t think the one coming out shortly contains the Safari 4 fixes, but the following one will. Hope this helps.

  5. Bob Beckman March 25, 2009 at 3:47 pm #

    Are we ever going to get the Study tools add in? It was in and out of this beta cycle several times. I got used to using it, and was disappointed when it disappeared. What’s the scoop?

  6. Phil Gons March 25, 2009 at 4:01 pm #

    Although there’s a lot of benefit to the Study Templates Addin (formally Study Tools Addin) as it is, there are some additional things that we’d like to do to it before we ship it. Sorry for keeping you waiting so long!

  7. Scot Tomlinson March 25, 2009 at 5:55 pm #

    What ever happened to version 4? I thought I remember seeing some screen shots some time back. When is “4″?

  8. Phil Gons March 25, 2009 at 9:48 pm #

    Our team of developers is working hard on the next major version. No ETA yet, but I hear they are making some really great progress.

  9. Jimmy March 26, 2009 at 3:10 am #

    Can I order the update on a disk? My internet connection is very slow.
    Thanks,
    Jimmy

  10. Phil Gons March 26, 2009 at 8:56 am #

    Jimmy, a media-only DVD or CDs is available for $4.95 for situations just like yours.

  11. Len Flack March 26, 2009 at 9:40 am #

    Thanks, Phil! It does help. I’m sure that trying to deal with another company’s [still beta] software that breaks certain functionality in Logos is annoying. I’m thankful for all you folks do, and for how responsive the support team was in figuring out how to fix my system (in my case, that meant downgrading back to Safari 3).

  12. Ron March 29, 2009 at 7:46 pm #

    I don’t use the internet on the computer that I have Logos installed so do I need the update?
    Thanks,
    Ron

  13. Phil Gons March 30, 2009 at 1:09 pm #

    Ron, while it’s best to always be running the latest version of the software, if you don’t plan on updating to Internet Explorer 8, it’s not essential that you update to Libronix DLS 3.0f.

  14. Marilyn Martina April 2, 2009 at 4:50 am #

    How do I open these new addins in 30f: Character Study, Fallahee Method, Original Language Exegetical Template, Mueller Method for New Testament Exegesis? I noticed they are in the directory.

  15. Carlton King January 15, 2010 at 7:14 pm #

    I’m using LDLS Version 1.1a on Vista Ultimate; when I try to go Tools/Libronix Update, I get the following error:
    Line 46 (LibronixUpdate.html): Object required
    Shell: “lbxfile:C:%5CProgram%20Files%20%28×86%29%5CLibronix%20DLS%5CCommon%5CLDLS%5CShells%5CLDLS-en” [en-US] 2002-09-13T17:47:01Z
    IE: 8.0.6001.18865 0
    Windows: SP2 (6.0.6002.2.0)
    Have downloaded the 3.0 updates but cannot get it to execute. I’m sure there’s a simple solution (like probably ordering the DVD, etc.), but presently I’m at wits end.

  16. Phil Gons January 18, 2010 at 9:25 am #

    Carlton, someone in our Customer Service department would be happy to help you get updated to the latest version of Libronix, which is 3.0g. Just call 800-875-6467 or email support@logos.com. However, if you haven’t heard, Logos 4 is now out and we’re having special discounted pricing on upgrades through the end of the month. Visit http://www.logos.com/upgrade to see the deals we have for you.

  17. JAMES January 13, 2013 at 7:55 am #

    Please,
    Windows 8 and Libronix.
    Do you have some news about upgrade?
    Thanks.